Omnicasa software Solutions - Problem with Mass mailings ! – Incident details

Problem with Mass mailings !

Resolved
Partial outage
Started about 1 month agoLasted about 3 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have been experiencing problems with the mass mailings .

    We are working with our supplier to resolve it as soon as possible.