Omnicasa software Solutions - Problems launching Omnicasa – Incident details

Problems launching Omnicasa

Resolved
Major outage
Started 3 days agoLasted 13 minutes

Affected

App

Major outage from 12:14 PM to 12:28 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have issues with launching Omnicasa . We've already identified the problem and are working on it to solve it as quickly as possible.

    We will keep you updated.